SSL-certificaat op een MikroTik-router

Eenmalig een template aanmaken:

/certificate add name=ssl-template common-name=<FQDN van de router> \
    key-size=4096 organization="<organisatie>" country=NL

Creëer een (nieuw) CSR (Certificate Signing Request):

/certificate create-certificate-request template=ssl-template \
    key-passphrase="<wachtwoord>"

Er zijn nu twee bestanden aangemaakt:

  • certificate-request.pem
  • certificate-request_key.pem

Download deze en gebruik de eerste om een certificaat aan te maken, bijvoorbeeld bij StartSSL*.

Upload het verkregen certificaat naar de router.

Importeer het certificaat:

/certificate import file-name=<bestandsnaam certificaat> passphrase=""

Importeer de sleutel:

/certificate import file-name=certificate-request_key.pem passphrase="<wachtwoord>"

Gebruik het (nieuwe) SSL-certificaat voor bijvoorbeeld de https-versie van Webfig:

/ip service set www-ssl certificate=<naam van het certificaat>

Ik moest de router herstarten voordat het nieuwe certificaat ook echt gebruikt werd, maar dat kan aan mij liggen. Misschien kan het makkelijker en sneller.

*) Toevoeging 28 september 2016: na het schandaal rond WoSign/StartCom (zie Mozilla gaat certificaatauthoriteit WoSign/StartCom straffen) wordt het gebruik van SSL-certificaten van StartSSL afgeraden.

Eigen router achter een XS4ALL-VDSL-aansluiting (3)

Sinds ruim een jaar heb ik gebruik een eigen router achter een VDSL-aansluiting van XS4ALL. Hoe ik dat destijds werkend heb gekregen staat hier beschreven.

Inmiddels heeft het modem (Draytek Vigor 130 VDSL2-modem) een paar firmware-updates gehad en een bezoeker van dit blog (Rob, 18 juni 2015 om 01:16) wees mij erop dat de VLAN tag insertion nu wél door het modem zelf uitgevoerd kan worden. Bovendien kan de MTU nu op 1500 gezet worden, waardoor er geen of minder MTU-problemen meer optreden.

Wie ook IPTV van XS4ALL heeft (wat over VLAN 4 loopt) kan het wellicht beter bij de oude setup houden.

De afgelopen maand heb ik de nieuwe opzet naar volle tevredenheid gebruikt. Ook na een stroomstoring kwam de verbinding zonder problemen weer op.

Lees verder

Unlocken en upgraden van een Huawei Ascend G525

De Huawei Ascend G525 is best een aardig toestel. Jammer dat Huawei er geen enkele update voor heeft uitgebracht en dat je met bloatware (Twitter, Facebook) blijft zitten. Nu mijn exemplaar toch niet meer door garantie gedekt wordt, is het een mooi moment om het toestel van een custom ROM te voorzien. Fabrikant Xiaomi heeft er zowaar een uitgebracht op basis van Android 4.4.4. Weliswaar zonder Google Apps, maar zelfs daar is wat aan te doen.

Lees verder

Gebruik van een IPv6-subnet op een rootserver bij Hetzner

Bij Hetzner in Duitsland huur ik enkele rootservers, voornamelijk vanwege de goede prijs/kwaliteitverhouding en omdat Hetzner ook IPv6-connectiviteit al lang standaard aanbiedt.

Op elke rootserver draaien enkele virtuele machines op basis van KVM. Het configureren hiervan is altijd wat lastig geweest, omdat Hetzner het netwerkverkeer alleen aflevert op het MAC-adres van de fysieke ethernetaansluiting. (Op zich is daar een goede reden voor: anders loopt de ARP-cache van de switch of router binnen de kortste keren vol.) Lees verder

Derde leven voor Samsung Galaxy Ace S5830

'Aside'

Android Gingerbread 2.3.7
ROM: http://forum.xda-developers.com/showthread.php?t=2375459

Bekende bug + fix:
behalve bij het eerste gebruik, werkt de USB Mass Storage niet goed. Gebruik deze aparte app: http://forum.xda-developers.com/showthread.php?t=2706621

App om gemakkelijk in Recovery te kunnen booten:
Quick Boot (Reboot) https://play.google.com/store/apps/details?id=com.siriusapplications.quickboot

App voor het verplaatsen van apps tussen interne opslag en SD-kaart:
Link2SD https://play.google.com/store/apps/details?id=com.buak.Link2SD

 

 

Eigen router achter een XS4ALL-VDSL-aansluiting (2)

[Update 15-7-2015: naar aanleiding van een van de reacties heb ik een nieuwe versie van dit artikel geschreven.]

Een paar maanden geleden probeerde ik een eigen router werkend te krijgen op een VDSL-aansluiting van XS4ALL. Dat was toen maar matig succesvol, omdat de PPPoE-sessie vanaf de router niet robuust genoeg was.

Inmiddels heb ik het experiment kunnen herhalen, dit keer gelukkig met meer succes. Mede dankzij dit artikel van Peter Buijsman heb ik alles werkend gekregen. Lees verder

Eigen router achter een XS4ALL-VDSL-aansluiting

Als je een VDSL-verbinding van XS4ALL neemt, krijg je al een tijd lang als modem de onvolprezen FRITZ!Box 7360. Dit apparaat biedt, naast de modemfunctie, leuke extra mogelijkheden als wifi en telefonie (dect, voip, antwoordapparaat).

Wil je wat meer in je netwerk, zoals de mogelijkheden van IPv6 ten volle benutten, dan loop je al snel tegen de beperkingen* van de Fritzbox aan. Dat is niet gek, de Fritzbox is echt bedoeld voor consumenten, maar het is wel jammer. Lees verder

Acquisitiefraude: het Bel-me-niet Register helpt (een beetje)

Acquisitiefraude blijft een hardnekkig probleem en ook ik ontkom er niet aan. Gemiddeld eens per maand heb ik wel iemand aan de telefoon die een poging komt doen.

Bij de nieuwste variant die ik ken doet de beller net alsof de lijn slecht is en hij mij ineens niet meer kan horen. Het is me overigens niet duidelijk wat de strategie hierachter is en hoe dit tot “succes” voor de fraudeur moet leiden. Lees verder