Mobiel internet (3G) met een MikroTik-router

Als ik op vakantie ben in het buitenland wil ik toch internet op m’n laptop kunnen gebruiken. Ik koop dan ter plaatse een SIM-kaart met prepaid internet. In Frankrijk gebruik ik bijvoorbeeld Orange Let’s Go. Met behulp van een MikroTik-router met 3G-USB-modem heb ik dan meteen ook een eigen wifi-hotspot voor m’n gezin.

Lees verder

SSL-certificaat op een MikroTik-router

Eenmalig een template aanmaken:

/certificate add name=ssl-template common-name=<FQDN van de router> \
    key-size=4096 organization="<organisatie>" country=NL

Creëer een (nieuw) CSR (Certificate Signing Request):

/certificate create-certificate-request template=ssl-template \
    key-passphrase="<wachtwoord>"

Er zijn nu twee bestanden aangemaakt:

  • certificate-request.pem
  • certificate-request_key.pem

Download deze en gebruik de eerste om een certificaat aan te maken, bijvoorbeeld bij StartSSL*.

Upload het verkregen certificaat naar de router.

Importeer het certificaat:

/certificate import file-name=<bestandsnaam certificaat> passphrase=""

Importeer de sleutel:

/certificate import file-name=certificate-request_key.pem passphrase="<wachtwoord>"

Gebruik het (nieuwe) SSL-certificaat voor bijvoorbeeld de https-versie van Webfig:

/ip service set www-ssl certificate=<naam van het certificaat>

Ik moest de router herstarten voordat het nieuwe certificaat ook echt gebruikt werd, maar dat kan aan mij liggen. Misschien kan het makkelijker en sneller.

*) Toevoeging 28 september 2016: na het schandaal rond WoSign/StartCom (zie Mozilla gaat certificaatauthoriteit WoSign/StartCom straffen) wordt het gebruik van SSL-certificaten van StartSSL afgeraden.

Eigen router achter een XS4ALL-VDSL-aansluiting (3)

Update 22 februari 2017: naar aanleiding van een nieuwe versie van de firmware van de Draytek Vigor 130 heb ik een nieuwe versie van dit artikel geschreven: Eigen router achter een XS4ALL-VDSL-aansluiting (4).

Sinds ruim een jaar heb ik gebruik een eigen router achter een VDSL-aansluiting van XS4ALL. Hoe ik dat destijds werkend heb gekregen staat hier beschreven.

Inmiddels heeft het modem (Draytek Vigor 130 VDSL2-modem) een paar firmware-updates gehad en een bezoeker van dit blog (Rob, 18 juni 2015 om 01:16) wees mij erop dat de VLAN tag insertion nu wél door het modem zelf uitgevoerd kan worden. Bovendien kan de MTU nu op 1500 gezet worden, waardoor er geen of minder MTU-problemen meer optreden.

Wie ook IPTV van XS4ALL heeft (wat over VLAN 4 loopt) kan het wellicht beter bij de oude setup houden.

De afgelopen maand heb ik de nieuwe opzet naar volle tevredenheid gebruikt. Ook na een stroomstoring kwam de verbinding zonder problemen weer op.

Lees verder

Eigen router achter een XS4ALL-VDSL-aansluiting (2)

[Update 15-7-2015: naar aanleiding van een van de reacties heb ik een nieuwe versie van dit artikel geschreven.]

Een paar maanden geleden probeerde ik een eigen router werkend te krijgen op een VDSL-aansluiting van XS4ALL. Dat was toen maar matig succesvol, omdat de PPPoE-sessie vanaf de router niet robuust genoeg was.

Inmiddels heb ik het experiment kunnen herhalen, dit keer gelukkig met meer succes. Mede dankzij dit artikel van Peter Buijsman heb ik alles werkend gekregen. Lees verder